
	
   	
  

 

Dear Candidate, 

In preparation for the Web Communication certification exam, we’ve put together a set of practice 
materials and example exam items for you to review.  What you’ll find in this packet are: 

§ Topic areas and objectives for the exam.  

§ Practice materials with image assets. 

§ Practice exam items. 

We’ve assembled excerpted material from the Digital Design Curriculum guide to highlight a few of 
the more challenging techniques covered on the exam.  You can work through these technical guides 
with the provided files (provided separately). Additionally, we’ve included the certification objectives 
so that you are aware of the elements that are covered on the exam. Finally, we’ve included practice 
exam items to give you a feel for some of the items.  

These materials are meant to help you familiarize yourself with the areas of the exam so are not 
comprehensive across all the objectives. 

Thank you, 

Adobe Education 
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Adobe Web Authoring using Adobe Dreamweaver 
Exam and objectives 

After taking the exam, your score is electronically reported.  Please allow 2-4 weeks from the date you pass 
the exam to receive your ACA Welcome Kit. 

Exam Structure 
 
The following lists the topic areas for the exam: 

1. Setting project requirements 
2. Planning site design and page layout 
3. Understanding the Adobe Dreamweaver interface 
4. Adding content by using Dreamweaver 

5. Organizing content by using Dreamweaver 
6. Evaluating and maintaining a site by using Dreamweaver  

Number of Questions and Time  
 

• 41 questions  

• 50 minutes  

 
Exam Objectives 

Domain 1.0 Setting Project Requirements 

1.1 Identify the purpose, audience, and audience needs for a website. 

1.2 Identify web page content that is relevant to the website purpose and appropriate for the target audience. 

1.3 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material).  

1.4 Demonstrate knowledge of website accessibility standards that address the needs of people with visual and 
motor impairments. 

1.5 Make website development decisions based on your analysis and interpretation of design specifications. 

1.6 Understand project management tasks and responsibilities. 

Domain 2.0 Planning Site Design and Page Layout 

2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, such as 
maintaining consistency, separating content from design, using standard fonts, and utilizing a visual hierarchy. 

2.2 Produce website designs that work equally well on various operating systems, browser versions/configurations, 
and devices.  

2.3 Demonstrate knowledge of page layout design concepts and principles. 

2.4 Identify basic principles of website usability, readability, and accessibility. 

2.5 Demonstrate knowledge of flowcharts, storyboards, wireframes, and design comps to create web pages and a 
site map (site index) that maintain the planned website hierarchy. 

2.6 Communicate with others (such as peers and clients) about design plans. 
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Domain 3.0 Understanding the Adobe Dreamweaver Interface 

3.1 Identify elements of the Dreamweaver interface. 

3.2 Use the Insert panel. 

3.3 Use the Property Inspector. 

3.4 Use the Assets panel. 

3.5 Use the Files panel. 

3.6  Customize the workspace 

Domain 4.0 Adding Content by Using Dreamweaver 

4.1 Demonstrate knowledge of Hypertext Markup Language. 

4.2  Define a Dreamweaver site. 

4.3 Create, title, name, and save a web page. 

4.4 Add text to a web page. 

4.5 Insert images and apply alternative text on a web page. 

4.6 Link web content, using hyperlinks, e-mail links, and named anchors.  

4.7 Include video and sound in a web page.  

4.8 Insert animation and interactivity to content. 

4.9 Insert navigation bars, rollover images, and buttons created in a drawing program on a web page.  

4.10 Import tabular data to a web page. 

4.11 Import and display a Microsoft Word or Microsoft Excel document to a web page. 

4.12 Create forms. 

Domain 5.0 Organizing Content by Using Dreamweaver 

5.1 Set and modify document properties. 

5.2 Organize web page layout with relative and absolutely-positioned div tags and CSS styles. 

5.3 Modify text and text properties. 

5.4 Modify images and image properties. 

5.5 Create web page templates. 

5.6 Use basic HTML tags to set up an HTML document, format text, add links, create tables, and build ordered and 
unordered lists. 

5.7 Add head content to make a web page visible to search engines.  

5.8 Use CSS to implement a reusable design.  

Domain 6.0 Evaluating and Maintaining a Site by Using Dreamweaver CS6 

6.1 Conduct technical tests.  

6.2 Identify techniques for basic usability tests. 

6.3 Identify methods for collecting site feedback. 

6.4 Manage assets, links, and files for a site.  

6.5 Publish and update site files to a remote server.  
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Introduction to HTML and CSS
Before you learn about Cascading Style Sheets (CSS), you should have a basic understanding of HTML, the 
programming language used to create web pages.

The structure and appearance of a web page is controlled by its underlying code. The programming language used to 
write this code for web pages is Hypertext Markup Language, or HTML.

If you view the code for most web pages, you will see line after line of ordinary text, surrounded by short commands 
called HTML tags. These tags are placed in brackets at the beginning and end of blocks of text and tell a web browser 
how to display or interact with information between the tags. Tags are enclosed by angle brackets (<>) and usually 
come in pairs with a start (or opening) and end (or closing) tag. The example shows two HTML tags that tell a web 
browser where a paragraph of text begins and ends (Figure 1). The HTML tags themselves are not displayed in the 
browser.

Figure 1 Sample HTML tags

When you create a web page by using Dreamweaver in Design view, the HTML code is created automatically. These 
are common tags you will see when working in Dreamweaver:

• <html></html> describes the web page

• <head></head> describes the header of the web page

• <body></body> describes visible page content

• <h1></h1> displays a heading, ranging in size from 1 (biggest) to 6 (smallest)

• <p></p> formats text as a paragraph

• <strong></strong> bolds text

• <em></em> emphasizes text, displays as italics

• <br> creates a line break

• <a href="http://www.example.com"></a> creates a link to a web page

Note: Dreamweaver uses code coloring to help you identify general categories of tags and code elements in Code 
view. 

Although HTML includes tags for displaying text, images, tables, and other page elements, it has limited precision in 
page layout and formatting—a frustration for many designers. 

Cascading Style Sheets (CSS) is a collection of formatting rules that control the appearance of content (such as 
HTML tags) in a web page. Using CSS styles to format a page separates content from presentation. The content of 
your page—the HTML code and tags—resides in the HTML file, and the CSS rules defining the presentation of the 
code reside in another file (an external style sheet) or in another part of the HTML document (usually the head 
section). Separating content from presentation mean you can more easily maintain the appearance of your site from a 
central location, because you don’t need to update every property on every page whenever you want to make a 
change. Separating content from presentation also results in simpler and cleaner HTML code, which provides shorter 
browser loading times and simplifies navigation for people with accessibility issues (for example, those using screen 
readers).

<p>This is a paragraph of text.</p>

Paragraph starting tag Paragraph ending tag
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If you have worked with styles in other programs, such as a word processor, you are already familiar with the basic 
function of CSS. In CSS, a style is simply a rule describing how to format content on a web page. A CSS (style sheet) 
is a collection of these rules.

About CSS rules

A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):

h1 { 

font-family: Georgia, "Times New Roman", Times, serif;

font-size: 18px;

text-transform: uppercase;

color: #090; 

}

An individual declaration consists of two parts: the property (such as font-family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, and uppercase, and [color 090]. 

The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 2). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.

Figure 2 Updating a CSS rule in one place updates all elements

There are three main types of CSS:

Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 
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HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.

ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 

CSS rules can reside in the following locations:

External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. For more information about how to work with external CSS files, see the How to work with external 
Cascading Style Sheets document

Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section 
of an HTML document.

Inline styles places the CSS style attribute inside the relevant tag throughout an HTML document. (Using Inline 
styles is not recommended because it mixes content with presentation. If this method is used, you should do so 
sparingly.)

Evolution of HTML and CSS

HTML and CSS are web standards that are constantly evolving. 

HTML5 is the fifth iteration of HTML and adds tags to support multimedia elements and dynamic graphics in 
modern web browsers and across various devices. CSS3 defines a new set of modular rules for how HTML content is 
presented in web browsers.

In Dreamweaver, you can create and edit HTML5-based web pages. Dreamweaver provides code hints for HTML5 
elements and CSS3 styles when you build pages in the Code View window. Starter layouts are also available for 
building HTML5 pages from scratch.

You should observe the following best practices when authoring HTML5 pages:

• Use <!doctype html> to tell browsers the web page is formatted with HTML5.

• Use <meta charset="utf-8"> to tell browsers which character-set is in use in the document.

• Use the semantic markup tags <article>,  <section>, <header>,  <nav>, and others to bring a higher 
level of structural meaning to HTML5 documents.

• Design and test content across a range of browsers and devices that support HTML5 capabilities.

Review these HTML5 and CSS3 resources from the W3C:

• W3C HTML5 specifications: http://dev.w3.org/html5/spec/single-page.html

• HTML5 differences from HTML4: www.w3.org/TR/html5-diff/

• W3C CSS home page: www.w3.org/Style/CSS/ 
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Overview of Adobe Dreamweaver
You can access Adobe Dreamweaver tools, commands, and features by using menus or by selecting options from one 
of the Insert panels or other Dreamweaver panels. The most commonly used areas of the Dreamweaver workspace 
(Figure 1) are the Document window, the Insert panel, the Properties panel, and the other panels.

The Document window displays the current document as you create and edit it. The Insert panel contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Properties inspector displays properties for the selected object or text and enables you to modify those 
properties. 

The Document window and panels

The Dreamweaver workspace (Figure 1) enables you to view documents and object properties. The workspace 
places many of the most common operations in toolbars so that you can quickly make changes to your documents.

Figure 1 Dreamweaver workspace, Split view (Code and Design)

Switching between views

Dreamweaver enables you to work in a variety of views. Lay out a page graphically in Design view, work directly 
with the underlying code, split the screen into both Code and Design views, or edit in Live view which presents a 
non-editable browser-based rendering of the document as you create and edit it. Change views by using the view 
buttons.

• Code view a hand-coding environment for writing and editing HTML, JavaScript, server-language code—
such PHP or ColdFusion Markup Language (CFML)—and any other kind of code. 

Application bar Document toolbar Workspace switcher Insert panel

Files panel

Document window

Design viewCode viewProperties panel

View buttons
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• Design view a design environment for visual page layout, visual editing, and rapid application development. 
In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what 
you would see when viewing the page in a browser.

• Code and Design view (Split view) both Code view and Design view for the same document in a single 
window.

There are also two additional views related to code that dynamically changes the page--that is, code that will change 
as users interact with the page:

• Live view similar to Design view, a more realistic representation of what your document will look like in a 
browser. Live view enables you to interact with the document exactly as you would in a browser. Live view 
is not editable. However, you can edit in Code view and refresh Live view to see your changes.

• Live Code view only available when viewing a document in Live view. Live Code view displays the actual 
code that a browser uses to execute the page, and can dynamically change as you interact with the page in 
Live view. Live Code view is not editable.

To select a view, click its button in the Document toolbar (Figure 1).

Dreamweaver workspaces

You can also manage panels by using workspaces. Workspaces are pre-arranged panel settings optimized for specific 
tasks or work styles. 

To switch between workspaces:

1. Select a new workspace, such as the Expanded 
workspace, from the workspace switcher in the 
Application bar (Figure 2).

The panels are rearranged.

Figure 2 Workspace switcher

To create a new workspace:

1. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.

2. Choose Window > Workspace Layout > New Workspace.

The New Workspace dialog box (Windows) or Save 
Workspace dialog box (Mac OS) opens (Figure 3).

3. Enter a name for the new workspace.

4. Click OK.

The workspace is now available in the workspace 
switcher and the Workspace Layout menu (Figure 4).

Figure 3 New Workspace dialog box

Figure 4 New Workspace in the switcher
Overview of Adobe Dreamweaver © 2013 Adobe Systems Incorporated
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Panels

Depending on the selected workspace, the right side of the workspace displays panels. 

Panel groups

Panels are often arranged into groups. Panel groups are panels that are docked together. For example, the Insert and 
Files panels are docked together by default in the Compact workspace (Figure 5).

Figure 5 Panel group

• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.

• To rearrange panels in a group, drag a panel’s tab to a new location in the group.

• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.

• To move a floating group, drag the title bar (the area above the tabs) (Figure 6).

Working with Panels

• Opening and closing panels: To open a panel, select it from the Window menu. To close a panel, do one of 
the following:

◦ Click the Close button at the top of a floating panel.

◦ Choose Close from the panel menu.

◦ Deselect the panel in the Window menu.

• Moving panels and panel groups. To move a panel, drag it by its tab. To move a panel group or a stack of 
floating panels, drag the title bar.To dock a panel, drag the panel until the border changes to blue. Release the 
mouse to dock the panel. To undock the panel, drag it away from the left border.

• Minimizing or maximizing panels: To minimize or maximize a panel, double-click the tab or the tab area (the 
empty space next to the tab).

• Collapsing panels: Collapsing a panel makes it available as an icon (Figure 6). To collapse or expand a 
panel, do one of the following:

◦ Click the double arrow in a floating panel's title bar.

◦ Double-click the tab area.

◦ Double-click the title bar of a floating panel or group.

Figure 6 Collapsed panel

Expand panels/Collapse To Icon buttonTitle bar

Close panel
© 2013 Adobe Systems Incorporated Overview of Adobe Dreamweaver 3
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• Docking and undocking panels: As you move panels, you see blue highlighted drop zones. Drop zones are 
areas where you can dock the panel. If you drag to an area that is not a drop zone, the panel floats freely in 
the workspace.

• Resizing panels: To resize a panel, drag either its left or bottom border. All panels have a minimum size 
beyond which they cannot be minimized. Panels can be maximized to fill your screen.

Commonly used panels

The Files panel displays the organization of your site and enables you to open files for editing, to publish files to a 
server, or to delete files.

The Assets panel contains all site assets, elements used in a site, such as images, colors, or movies. To view the 
Assets panel, choose Window > Assets. The Assets panel provides two ways to view assets:

• The Site list shows all of the assets in your site.

• The Favorites list shows only the assets you’ve chosen to include in the Favorites list.

The Insert panel

The Insert panel contains buttons for creating and inserting objects such as tables, images, and links (Figure 7). The 
buttons are organized into several categories (Common, Structure, Media, Form, and more), which you can choose 
from the Category pop-up menu. Additional categories appear when the current document contains server code, such 
as ASP or CFML documents.

Figure 7 The Insert panel

Category popup menu
Overview of Adobe Dreamweaver © 2013 Adobe Systems Incorporated
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The Common category in the Insert panel contains buttons for inserting the most commonly used objects, such as 
images and tables.

From the Structure category, you can insert lists, headings, paragraphs and other tags. 

The Media category provides options for video, audio, Flash, and plugin objects.

The Property inspector

The Property inspector lets you examine and edit the most common properties for the currently selected page 
element, such as text or an inserted object. The contents of the Property inspector vary depending on the element 
selected. Figure 8 shows the Property inspector for a selected image. It displays the source location, Alt tag, 
dimensions, and class. You can edit these settings and create links in the Property inspector.

Figure 8 Property inspector

The Property inspector is at the lower edge of the workspace by default, but you can undock it and make it a floating 
panel in the workspace.
© 2013 Adobe Systems Incorporated Overview of Adobe Dreamweaver 5
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How to create and edit a CSS rule
You can quickly and easily create and edit a CSS rule in the CSS Designer panel. The CSS Designer panel is an 
integrated panel that lets you 'visually' create CSS rules, and set properties in either internal or external files.

In this guide, you review the components of CSS rules, then create and apply internal CSS rules using the CSS 
Designer panel.

About CSS rules

A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and}) is the declaration block (defining the properties of the h1 heading):

h1 { 

font-family: Georgia, "Times New Roman", Times, serif;

font-size: 18px;

text-transform: uppercase;

color: #090; 

}

An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 

The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS makes updates extremely easy. When you update a CSS rule in 
one place, the formatting of all the elements that use the defined style is automatically updated to the new style.

Figure 1 Updating a CSS rule in one place updates all elements
© 2013 Adobe Systems Incorporated How to create and edit a CSS rule 1

This document requires Adobe Dreamweaver CC, June 2013. Technical instructions may differ depending on your version.



Guide Adobe Dreamweaver

2

There are three main types of CSS:

Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, myhead1). 

HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.

Advanced styles: Redefine the formatting for a particular combination of elements, or for other selector forms as 
allowed by CSS (for example, the selector td h2 applies whenever an h2 header appears inside a table cell.) 
Advanced styles can also redefine the formatting for tags that contain a specific id attribute (for example, the 
styles defined by #myStyle apply to all tags that contain the attribute-value pair id=”myStyle”). 

CSS rules can reside in the following locations:

External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 

Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section 
of an HTML document.

Inline styles places the CSS style attribute inside the relevant tag throughout an HTML document. (Inline styles 
can be created using the Properties Inspector, although is not recommended as this method mixes content with 
presentation. If used, do so sparingly.)

Dreamweaver recognizes styles defined in existing documents as long as they conform to CSS style guidelines. 
Dreamweaver also renders most applied styles directly in Design view. (Previewing the document in a browser 
window, however, gives you the most accurate “live” rendering of the page.) Some CSS styles are rendered 
differently in Microsoft Internet Explorer, Netscape, Opera, Apple Safari, or other browsers, and some are not 
currently supported by any browser.

By default, Dreamweaver uses Cascading Style Sheets (CSS) to format text. You can use the CSS Designer panel as 
the primary tool for creating and editing your CSS. The CSS Designer panel is an editing tool that helps you generate 
clean web-standard code that lets you 'visually' create CSS files, rules, and set properties, along with media queries. 

Using the CSS Designer panel

In the CSS Designer panel you can track the CSS rules and properties affecting a currently selected element. CSS 
Designer is context-sensitive. This means, for any given context or selected page element, you can view the 
associated selectors and properties. Further, when you select a selector in CSS Designer, the associated source and 
media queries are highlighted in the respective panes.
How to create and edit a CSS rule © 2013 Adobe Systems Incorporated
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Figure 2 CSS Designer panel

The CSS Designer panel consists of the following panes (Figure 2):

• Sources Lists all the style sheets associated with the document. Using this pane, you can create and attach a 
CSS to the document, or define styles within the document.

• @Media Lists all the media queries in the source selected in the Sources pane. If you do not select a specific 
CSS, this pane displays all the media queries associated with the document.

• Selectors Lists all the selectors in the source selected in the Sources pane. If you also select a media query, 
this pane narrows down the list of selectors for that media query. If no CSS or media queries are selected, 
this pane displays all the selectors in the document. When you select Global in the @Media pane, all the 
selectors that are not included in a media query of the selected source are displayed.

• Properties Displays properties that you can set for the specified selector. 

Create and attach style sheets

There are several ways to create and attach style sheets: by creating a new external CSS file; by using an existing 
external CSS file; or by defining CSS rules internally within your HTML document. You will use this last method, 
using internal CSS rules, to create styles sheets that are included in a style tag in the head section of an HTML 
document. For more information about how to create new, and use existing external CSS files, see the guide How to 
work with external Cascading Style Sheets.
© 2013 Adobe Systems Incorporated How to create and edit a CSS rule 3
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In this section, you will create a new HTML page, add a heading and paragraph, and apply basic text styles. After you 
complete these steps, be sure to continue experimenting with the CSS Designer panel to visually edit the rules and set 
properties.

How to define a CSS rule within a document:

1. Start Dreamweaver.

2. Select File > New to create a new document.

The New Document dialog box appears (Figure 3).

3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.

4. In the Layout column, select None. 

5. Click the Create button.

The new HTML page opens.

6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).

Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.

7. Place the cursor in document window in Design view, or 
between the <body> tags in Code view. This will be your 
page heading.

8. Select Window > Insert. 

The Insert panel opens (Figure 5).

9. Choose Structure from the Category popup menu.

10. Click the arrow on the Heading button, then select the H1 
option from the menu. 

Heading 1 placeholder text is inserted into the document 
(Figure 6).

11. In either the Design or Code view, select the text and 
retype a title for your page.

12. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text. This section will 
be paragraph text.

13. Type a larger section of text or paste text copied in 
another application in the Design view Document 
window. 

Figure 3 New Document dialog box

Figure 4 Document window view options

Figure 5 Insert panel

Figure 6 H1 placeholder text

Show Code And Design Views button

Category popup menu
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14. Choose Windows > CSS Designer.

The CSS Designer panel opens (Figure 7). 

Note: By default, the Properties pane is visible at the 
bottom of the panel. To see more of the Properties pane, 
undock the CSS Designer panel, mouse over the left edge 
and drag to expand the CSS Designer (Figure 8).

15. In the Sources pane of the CSS Designer panel, click the 
plus symbol to add a CSS source and choose Define in 
Page (Figure 9). 

The <style> tag is added to the head section of the 
HTML document. Any newly-defined CSS rules will be 
saved in this internal CSS style tag.

16. Select the heading text in the document window, in either 
the Design or Code view.

17. In the CSS Designer, choose the <style> source in the 
Sources pane (Figure 10) so that the internal CSS rules 
are selected. 

18.  In the Selectors pane, click the plus sign. Based on the 
element selected in the document, CSS Designer smartly 
identifies and prompts you with the relevant selector. In 
this case, the selector body h1 is applied (Figure 11). 
By default, the selector is 'More Specific'. You can edit 
the selector to make it 'Less Specific'.

The Properties pane displays the grouped categories 
represented by different icons at the top of the Properties 
pane:

• Layout

• Text

• Border

• Background

• Others (list of 'text only' properties and not 
properties with visual controls)

Figure 7 CSS Designer panel

Figure 8 Drag to expand CSS Designer panel

Figure 9 Select a CSS source

Figure 10 Choose the internal CSS rules

Figure 11 Identifying a selector
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19. In the Properties pane, click the Text icon (Figure 12).

20. In the Properties > Text pane, click font-family to open 
the list of available fonts.

A menu of available font opens (Figure 13). 

21. Select a serif font family such as ‘Constantia, Lucida 
Bright, DejaVu Serif, Georgia, serif.’

Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 

22. Select Uppercase using the text-transform option.

23. Select a color for the text using the color picker 
(Figure 14).

The font and color options are applied to the selected text 
(Figure 15).

24. Use the CSS Designer panel to set the font, color, and 
size properties for the paragraph text. For example, you 
might choose a sans-serif font, green, and font-size set to 
14px.

Observe in Code view that Dreamweaver updates the 
styles created with the CSS Designer panel directly in the 
head section of the document.

Figure 12 Properites pane

Figure 13 Font-family menu

Figure 14 Text color picker

Figure 15 H1 CSS in Code and Design view

Text properties
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How to publish web files
Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote 
server (often referred to as the web server) is where you publish your site files so that people can view them online. 
The remote server is simply another computer like your local computer, with a collection of files and folders on it. 
You specify a folder for your site on the remote server, just as you specified a folder for your local site on your local 
computer (Figure 1). Dreamweaver refers to the specified remote folder as your remote site.

Figure 1 Basic screen of the Servers category, Site Setup dialog box

When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web server 
and download files from your web server. The most typical connection method is FTP, but Dreamweaver also 
supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection 
method to use, ask your teacher or your school server administrator.

Connecting to a remote site

Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver. 

To connect to a remote site by FTP:

1. Select Site > Manage Sites.

The Manage Sites dialog box opens (Figure 2).

2. Double-click the name of the site you want to connect 
remotely.

The Site Setup dialog box opens.

Figure 2 Manage Sites dialog box
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3. Click the Servers category in the left column.

The Servers category of the Site Setup dialog box opens (Figure 3).

Figure 3 Basic screen of the Servers category, Site Setup dialog box

4. Click the Add New Server button (+).

5. Enter the FTP access information as directed by your teacher (Figure 1).

6. Click Test to test the connection.

Dreamweaver confirms the connection.

7. Click Save.

The new server appears in the list of servers in the Site Setup dialog box.

8. Click Save to close the Site Setup dialog box.

9. Click Done to close the Manage Sites dialog box.

Add New Server
How to publish web files © 2012 Adobe Systems Incorporated
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Uploading, Synchronizing, and downloading files

Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files panel 
(Figure 4).

Figure 4 Expanded Files panel

When you transfer a document between a local and remote folder using the Files panel, you have the option of 
transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 
referenced in your document that a browser loads when it loads the document.

Note: It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of 
the dependent files are already on the local disk, there’s no need to download them again. This is also true for 
uploading and checking in files: no need if up-to-date copies are already at the remote site.

To upload the entire site for the first time:

1. In the Files panel (Window > Files), select the files to 
upload.

2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 4).

The Files panel expands.

3. Click the Connects To Remote Host button in the Files 
panel toolbar.

Dreamweaver connects to the web server.

4. Select the root folder for your site in the Local (right) 
pane.

5. Click the Put Files button in the Files panel toolbar.

6. You may be presented with a dialog box asking if you 
wish to put the entire site. Click OK.

Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5).

Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.

Figure 5 Background File Activity dialog box

Connects/Disconnects Remote Host Get Files Put Files Synchronize Expand/CollapseRefresh
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To upload a revised version of an existing file:

1. Select the file you have revised.

2. Click the Put Files button in the Files panel toolbar.

Dreamweaver uploads the revised file.

Synchronizing the files on your local and remote sites

After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.

Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver 
also confirms which files have been updated after you complete the synchronization.

To synchronize files:

1. (Optional) Select specific files or folders in the Files 
panel or go to the next step to synchronize the entire site.

2. Click the Synchronize button in the Files panel toolbar to 
synchronize files.

The Synchronize Files dialog box opens (Figure 6).

3. Select the direction in which you want to copy the files:

Put Newer Files To Remote uploads all the local files that 
don’t exist on the remote server or have changed since 
the last upload.

Get Newer Files From Remote downloads all the remote 
files that don’t exist locally or have changed since the last 
download.

Get And Put Newer Files places the most recent versions 
of all the files on both the local and the remote sites.

4. Choose whether to delete the files on the destination site 
that don’t have counterparts on the origin site. (This is 
not available if you select Get and Put from the Direction 
menu.)

If you select Put Newer Files To Remote and you select 
the Delete option, then any files in your remote site for 
which there are no corresponding local files are deleted. 
If you select Get Newer Files From Remote, then any 
files in your local site for which there are no 
corresponding remote files are deleted.

Figure 6 Synchronize Files dialog box 
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5. Click Preview.

Dreamweaver analyzes the local and remote folders, and 
then the Synchronize dialog box opens (Figure 7).

Note: Before you can synchronize the files, you must 
preview the actions Dreamweaver performs to 
accomplish this task. 

If the newest version of each chosen file is already in 
both locations and nothing needs to be deleted, an alert 
appears informing you that no synchronization is 
necessary. Otherwise, the Synchronize dialog box 
appears to let you change the actions (put, get, delete, and 
ignore) for those files before executing the 
synchronization.

6. Verify the action that will be performed for each file.

7. Click OK to synchronize the files.

Figure 7 Synchronize dialog box 

Downloading files to work on them

Once your website has been published, you may want to download a file so you can revise it. You do so through the 
Remote Site pane, on the left side of the expanded Files panel.

To download a file:

1. Click the Refresh button in the Files panel toolbar 
(Figure 4) to make sure the files in the Remote Site pane 
are up-to-date.

2. Select a file to download.

3. Click the Get Files button.

If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). 

Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.

4. Click Yes.

Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.

5. Click the Disconnects From Remote Host button, and 
then collapse the Files panel.

Figure 8 Dependent Files dialog box 
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How to lay out a web page with CSS
A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to 
organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in 
most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div 
tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to 
existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can 
position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying their distance from other 
page elements). You can also position div tags by specifying floats, paddings, and margins—the preferred method by 
today’s web standards.

Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a simple 
two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly infinite number of 
combinations. Additionally, the problem of cross-browser rendering causes certain CSS layouts to display properly in 
some browsers and improperly in others. Dreamweaver makes it easy for you to build pages with CSS layouts by 
providing 16 pre-designed layouts that work across different browsers.

Using the pre-designed CSS layouts is the easiest way to create a page with a CSS layout, but you can also create CSS 
layouts by using absolutely-positioned elements (AP elements). An AP element in Dreamweaver is an HTML page 
element—specifically, a div tag or any other tag—that has an absolute position assigned to it (Figure 1). The 
limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their positions never 
adjust on the page in relation to the size of the browser window.

Once you become more experienced you will be able to create page layouts by inserting div tags manually and 
applying CSS positioning styles to them.

Figure 1 AP elements in the Dreamweaver Document window

Inserting an AP div tag

Start this activity by creating a new, blank page and inserting an AP div tag. AP elements can contain text, images, or 
any other content that you can place in the body of an HTML document.
© 2012 Adobe Systems Incorporated How to lay out a web page with CSS 1
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To insert an AP div tag:

1. Start Dreamweaver.

2. Select File > New.

The New Document dialog box opens (Figure 2).

3. With the Blank Page category selected, click HTML 
under Page Type and <none> under Layout.

4. Click Create.

A new untitled HTML document opens.

5. Save the new page.

The new file is added to the Files panel.

6. Select the Layout category in the Insert panel and 
confirm the Standard mode button is selected (Figure 3)

7. Click the Draw AP Div button.

The mouse pointer changes to a cross when you move it 
over the Document window.

8. To create the div that will define an area of your page, 
drag a rectangle in the Dreamweaver document. 

9. Click the border of the div to select it.

Handles appear along the border (Figure 4) and the div 
properties appear in the Properties panel. 

Figure 2 New Document dialog box

Figure 3 Insert panel, Layout category

Figure 4 Div inserted and selected
How to lay out a web page with CSS © 2012 Adobe Systems Incorporated
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10. Make sure the Properties panel is open (Figure 5). 

It is docked at the bottom of the screen. If the Properties 
panel is not open, select Window > Properties.

11. Click in the CCS-P Element ID box and enter a name for 
the div. 

Choose a unique name that will help you remember the 
div’s contents, such as header or navigation.

Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”.

12. Click the Bg Color box and select a color in the color 
picker. 

The div changes to the selected color. 

13. Click once outside the new div to deselect it. 

A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines.

14. Continue adding divs for all the sections on your page. 
You can place divs directly alongside one another 
(Figure 6).

15. Open the AP Elements panel (Window > AP Elements).

You’ll see that Dreamweaver has added the new divs to 
the list of AP Elements (Figure 7). 

Note: Select Prevent Overlaps to constrain the positions 
of AP elements when they are created, moved, and 
resized, so that they don’t overlap.

16. Save your page.

Figure 5 Properties panel

Figure 6 Multiple divs on page

Figure 7 AP Elements panel

Resizing divs

You can resize an individual div or simultaneously resize multiple divs to make them the same width and height.

Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.

CSS-P Element ID box
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To resize a div:

1. Select a div by clicking its border or by clicking the div’s 
name in the AP Elements panel.

2. Do one of the following to resize the div:

• To resize by dragging, drag any of the div’s resize 
handles (Figure 8).

• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key.

Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique.

• In the Properties panel, type values for width (W) 
and height (H).

Figure 8 Resize by dragging

Moving divs

You can move divs in Design view in much the same way you move objects in most basic graphics applications.

Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.

To move a div:

1. Select one or more divs.

2. Do one of the following:

• To move by dragging, drag the div’s selection handle 
(Figure 9).

• To move one pixel at a time, use the arrow keys.

Figure 9 Moving a div

Adding content to divs

You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a web 
page.

To add content to a div:

1. To insert an image in a div, click in the div and select 
Insert > Image.

Note: Make sure the div is sized large enough to hold the 
image or other content. If the div is sized smaller than the 
image, the div may not display correctly in all browsers.

Div resize handle

Selection handle
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2. In the Select Image Source dialog box, locate and select 
an image to insert (such as a page banner). Then click OK 
(Windows) or Open (Mac OS).

The image appears in the div (Figure 10).

3. To format the image in the div, select the image and 
select formatting elements in the Properties panel.

4. To add text to a div, click in the div and type text or paste 
text copied from another document.

Figure 10 Div with image added

Viewing div tags by using Live view

You can use a feature called Inspect mode in Live view to view the code generated by adding the div tags.  

To view div tags using by using Inspect mode in Live view:

1. Click the Live button in the Control panel (Figure 11).

Live view is enabled. This means that the page appears as 
it will in a web browser.

2. Click the Live button again to deactivate Live view.

3. Click the Split button. 

Code and Design view (Split view) view is enabled. This 
lets you see the code alongside the design display. 

4. Click the Live button again to activate Live Code view.

5. In the Design view, click on a div’s selection handle, or 
an image placed within a div and observe that the div tag 
is highlighted in the Code view (Figure 11).

Figure 11 Split Code/Live view

DivHighlighted tag

Live button
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How to preview and test a web project
Because you can't control which browsers or operating systems visitors will use to view your site, it is important to 
test your site in different browsers. You have two methods for previewing and testing a web project: from within 
Dreamweaver, using Live view, or using Preview in Browser (Figure 1).

Design view gives you an idea of how your page will look on the web but does not render pages exactly as browsers 
do. Live view presents a more accurate depiction, and lets you work in Code view so that you can see changes to the 
design. The Preview in Browser feature lets you see how your pages will look in specific browsers.

Figure 1 Dreamweaver Live view (left) and previewing in a browser (right)

Previewing pages in Dreamweaver

Live view differs from the traditional Dreamweaver design view in that it provides a non-editable, more realistic 
rendering of what your page will look like in a browser. Live view does not replace the Preview in Browser 
command, but rather provides another way of seeing what your page looks like “live” without having to leave the 
Dreamweaver workspace.

You can switch to Live view any time you are in Design view. Switching to Live view, however, is not related to 
switching between any of the other traditional views in Dreamweaver (Code/Split/Design). When you switch to Live 
view from Design view, you are simply toggling the Design view between editable and “live”.

While Design view remains frozen once you enter Live view, Code view remains editable, so you can change your 
code, and then refresh Live view to see your changes take effect. When you’re in Live view, you have the additional 
option of viewing live code. Live Code view is like Live view in that it displays a version of the code that the browser 
is executing in order to render the page. Like Live view, Live Code view is a non-editable view.

The technology behind Live view is WebKit, a layout engine software component that is the standard rendering 
engine for wide range of popular web browsers as Chrome, Safari, and many mobile devices. Recent WebKit 
improvements provides enhanced support for HTML5 and JavaScript in Live View.
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How to preview pages in Live view:

1. Open a file in Dreamweaver you want to preview 
(Figure 2).

2. Make sure that you are in Design view (View > Design) 
or Code and Design views (View > Code and Design).

3. Click the Live view button in the Document toolbar 
(Figure 3).

The web page content is previewed in the Design view 
window (Figure 4).

4. (Optional) Make your changes in Code view, in the CSS 
Styles panel, in an external CSS style sheet, or in another 
related file.

Even though you can’t edit in Live view, your options for 
making edits in other areas (for example, in the CSS 
Styles panel or in Code view) change as you click in Live 
view. 

Note: You can work with related files (such as CSS style 
sheets) while keeping Live view in focus by opening the 
related file from the Related Files toolbar at the top of the 
document.

5. If you’ve made changes in Code view or in a related file, 
refresh Live view by clicking the Refresh button in the 
Document tool bar (Figure 5), or by pressing F5.

6. To return to the editable Design view, click the Live view 
button again.

Figure 2 Project Design view

Figure 3 Document toolbar

Figure 4 Project Live view

Figure 5 Document toolbar

Live view button

Refresh button
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Previewing pages in browsers

You can preview a page in a browser at any time; you don’t have to upload it to a web server first. When you preview 
a page, all browser-related functions should work, including JavaScript behaviors, document-relative and absolute 
links, ActiveX® controls, and plug-ins, provided that you installed the required plug-ins or ActiveX controls in your 
browsers.

Before previewing a document, save the document; otherwise, the browser does not display your most recent 
changes.

How to preview pages in a browser:

1. Open a file in Dreamweaver you want to preview 
(Figure 2).

2. Select File > Preview In Browser, and then select one of 
the listed browsers (Figure 6).

The file opens in a browser window (Figure 8)

Note: If no browsers are listed, select Edit > Preferences 
or Dreamweaver > Preferences (Macintosh), and then 
select the Preview In Browser category on the left to 
define default primary and secondary browsers 
(Figure 7).

3. Click links and test content in your page.

Note: Content linked with a site root-relative path does 
not appear when you preview documents in a local 
browser unless you specify a testing server, or select the 
Preview Using Temporary File option in Edit > 
Preferences > Preview In Browser. This is because 
browsers don’t recognize site roots—servers do. To 
preview content linked with root-relative paths, put the 
file on a remote server, and then select File > Preview In 
Browser to view it.

4. If you make any changes to the file in Dreamweaver, be 
sure to hit the browser’s refresh button to see the most 
recent version.

5. Close the page in the browser when you finish testing.

Figure 6 Start top of column

Figure 7 Dreamweaver Preferences dialog box

Figure 8 Previewing a file in a browser
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How to manage files and links by using the Files panel
The Files panel in Dreamweaver helps you manage files and links. Use the Files panel to open, add, rename, or delete 
files and folders. Use the Files panel to modify links.

Opening files

Use the Files panel to view and manage the files in your Dreamweaver site. 

To open a file:

1. In the Files panel (Window > Files), select a site, server, 
or drive from the Current Sites pop-up menu (Figure 1).

2. In the Local Files section, navigate to the file you want to 
open.

3. Do one of the following:

• Double-click the files's icon.

• Right-click (Windows) or Control-click (Mac OS) 
the file's icon, then select Open.

Note: If Check In/Check Out is enabled, Dreamweaver 
will check the file out before it opens the file. If another 
visitor has checked out the file, Dreamweaver will warn 
you about the file’s status and let you know who has it 
checked out. You can then decide whether to continue 
opening the file or not.

Figure 1 Dreamweaver Files panel 

Renaming files

When you rename a file in the Files panel, Dreamweaver can automatically change links that point to this file. For 
this reason, it is always preferable to rename site files by using the Files panel instead of renaming them on your hard 
disk.

To rename a file:

1. In the Files panel, select the file or folder you want to 
rename.

2. Do one of the following to activate the name of the file or 
folder:

• Click the name, pause, and then click again.

• Right-click (Windows) or Control-click (Mac OS) 
the file or folder icon, and then select Edit > 
Rename.

3. Type the new name over the existing name.

4. Press Enter (Windows) or Return (Mac OS).

If any site links point to the file or folder, the Update 
Files dialog box opens (Figure 2).

5. Click Update to change links that point to the renamed 
file or to a file in the renamed folder.

Figure 2 Update Files dialog box

Current Sites menu
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Deleting files

When you delete a file or folder, Dreamweaver will warn you if links in other documents point to the file or folder. 

To delete a file:

1. Click the file or folder in the Files panel you want to 
delete.

1. Press Delete.

If any site links point to the file or folder, the Delete Files 
warning opens (Figure 3), giving you the opportunity to 
change the links before you delete the file.

To delete the file anyway, click Yes. To cancel your 
request to delete the file, click No.

Figure 3 Delete files dialog box

Changing links to a file

You can also change links to a file through the Files panel. It is a good practice to change links before you delete a file 
to which other files are linked.

To change links to a file:

1. Select a file in the Files panel.

1. Select Site > Change Link Sitewide.

The Change Link Sitewide dialog box opens (Figure 4).

2. In the Into Links To text box, enter the name of the file to 
which new links should point.

3. Click OK.

The Update Files dialog box opens (Figure 5).

4. Click Update.

Figure 4 Change Links Sitewide dialog box

Figure 5 Update Files dialog box

Creating a new folder

Use folders to keep your site well organized. For example, most websites use a folder named images to store all the 
images for the site.

To create a new folder:

1.  Select the site root folder (or another folder in which you 
want to create a nested folder).
How to manage files and links by using the Files panel © 2012 Adobe Systems Incorporated

This document requires Adobe Dreamweaver CS6. Technical instructions may differ depending on your version.



Adobe Dreamweaver Guide
2. In the Files panel menu (Figure 6), select File > New 
Folder.

Dreamweaver creates a new folder inside the selected 
folder. The folder name is selected.

3. Enter a name for the new folder and press Enter 
(Windows) or Return (Mac OS).

Figure 6 Files panel

Panel menu
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How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver, you can create a variety 
of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable images 
(such as a Submit button).

The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.

Figure 1 Forms category in the Insert panel

The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.

Setting up a form

You set up a form by inserting it and configuring options through the Properties panel.

To set up a form:

1. Open a page in Dreamweaver.

2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 

Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.
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3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 

A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.

Form options appear in the Properties panel.

4. From the Method pop-up menu in the Properties panel 
(Figure 3), select either GET or POST.

• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.

• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 

5. In the Action text box, type the URL or CGI script that 
will process the form.

Note: Get this information from your site administrator.

Figure 2 New, empty form

Figure 3 Forms Properties panel

Adding form elements

Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.

Using form fields

Form fields enable site visitors to enter text into a form. Form fields include the following:

• Text fields, in which a visitor types a response

• File fields, in which a visitor types the path of a file to upload to your server

Adding text fields

Text fields provide a space in which visitors can enter text.
How to create forms © 2012 Adobe Systems Incorporated

This document requires Adobe Dreamweaver CS6. Technical instructions may differ depending on your version.



Adobe Dreamweaver Guide
To add a text field:

1. Click the Text Field button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).

2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the text field in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).

The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.

3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 

The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.

4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

5. In the Add Form Tag dialog box, click Yes.

The text field appears in the form (Figure 5).

6. Click in the text field (not the label) to select it.

7. In the form Properties panel (Figure 6), select one of the 
three types of text fields:

• Single Line text for short answers

• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item

• Password text for passwords (in which asterisks 
appear in place of typed characters)

Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.

Figure 4 Input Tag Accessibility Attributes dialog 
box

Figure 5 Example of text field in the form

Figure 6 Form Text Field Properties panel

Adding a file field

A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.
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To add a file field:

1. Click the File Field button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens

2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the file field in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).

3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 

4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

The file field appears in your document (Figure 7).

5. Click in the file field (not the label) to select it. In the 
Properties panel, in the Char Width text box, specify the 
maximum number of characters visitors will see in the 
field (Figure 8).

6. In the Max Char text box, specify the maximum number 
of characters the field will hold.

Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            

Figure 7 File field example

Figure 8 Form File Field Properties panel

Using checkboxes and radio buttons

Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.

To add a checkbox:

1. Click the Checkbox button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens

2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the checkbox in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).

3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

The checkbox button appears in your document 
(Figure 9).

5. Click the checkbox (not the label) to select it.

6. In the Checked Value text box in the Properties panel 
(Figure 10), enter a value for the checkbox.

This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.

7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.

Figure 9 Example of checkbox

Figure 10 Form Checkbox Properties panel

To add a group of radio buttons:

1. Click the Radio Group button in the Insert panel to insert 
a group.

The Radio Group dialog box opens (Figure 11).

2. Enter a name in the Name text box.

3. Click the plus (+) button to add a radio button to the 
group.

4. Enter a label and (if you want) a checked value for each 
button.

5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.

6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 

7. Click OK.

The group of radio buttons is added to the form 
(Figure 12).

8. Click a radio button (not its label) to select it.

Figure 11 Radio Group dialog box

Figure 12 Example of Radio Group
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9. In the Properties panel, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).

Figure 13 Form Radio Button Properties panel

Using list menus and drop-down menus (List/Menu)

Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.

To add a list menu:

1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).

The Input Tag Accessibility Attributes dialog box opens.

2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the list menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore ( _ ).

3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 

4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

A list/menu field appears in your document (Figure 14).

5. Click the list/menu field (not its label) to select it.

6. In the Properties panel, for Type, select List (Figure 15).

Figure 14 Example of list/menu field

Figure 15 Form List Menu Properties panel
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7. In the Height text box, enter the number of items the list 
will display.

If this number is less than the total number of items in the 
list, a scroll bar will be displayed.

8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.

9. Click the List Values button to add the list items.

The List Values dialog box opens (Figure 16).

10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.

11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.

If you enter no value, then the form sends the label as the 
value for that item.

12. Press Enter (Windows) or Return (Mac OS).

13. To add another item to the list, click the plus (+) button.

14. When you finish, click OK to close the List Values dialog 
box.

Figure 16 List Values dialog box

Figure 17 Form List Menu Properties panel

15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Properties panel (Figure 18).

The Initially selected item appears in the form 
(Figure 18).

Figure 18 Form list with three items in the list

To add a drop-down menu:

1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).

The Input Tag Accessibility Attributes dialog box opens.

2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the pop-up menu in the ID text 
box. You may use any combination of letters, numbers, 
and an underscore (_).

3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.

A list/menu field appears in your document (Figure 19).

5. Click the list/menu field (not its label) to select it. 

6. In the Properties panel, for Type, select Menu.

7. Click the List Values button to add the menu items.

The List Values dialog box opens (Figure 20).

8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.

9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.

10. Press Enter (Windows) or Return (Mac OS).

11. To add another item to the menu, click the plus (+) 
button.

12. When you finish, click OK to close the List Values dialog 
box.

13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Properties panel. 

Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).

Figure 19 A list/menu field

Figure 20 List Values dialog box

Figure 21 Preview in a browser

Using form buttons

Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.

To add a standard text button:

1. Click the Button button in the Insert panel.

The Input Tag Accessibility Attributes dialog box opens.

2. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the button in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).

Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.
How to create forms © 2012 Adobe Systems Incorporated

This document requires Adobe Dreamweaver CS6. Technical instructions may differ depending on your version.



Adobe Dreamweaver Guide
3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.

Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the 
button’s value attribute, which you will set in the next 
step.

A text button appears in the document (Figure 22).

Note: In this example, a Submit button is placed below 
an existing file field.

4. Click the button to select it.

5. In the Properties panel’s Value text box, enter the text 
you want to appear on the button (Figure 23).

Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).

6. Select the type of Action (usually this is 
Submit Form).

Figure 22 Example of text button

Figure 23 Form Button Properties panel

Adding a graphical submit button

You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.

To add a graphical submit button:

1. Click the Image Field button in the Insert panel.

The Select Image Source dialog box appears (Figure 24).

2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Open (Mac OS).

The Input Tag Accessibility Attributes dialog box opens.

3. In the Input Tag Accessibility Attributes dialog box, 
enter a unique name for the button in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).

Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.

Figure 24 Select Image Source dialog box
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4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.

The graphical submit button appears in your document 
(Figure 25).

5. Click the button to select it.

6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.

Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.

Figure 25 Example of graphical submit button 

Figure 26 Form Image Field Properties panel

Using jump menus for navigation

A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.

To add a jump menu:

1. Click the Jump Menu button in the Insert panel.

The Insert Jump Menu dialog box opens (Figure 27).

2. Complete the dialog box.

For more information, click the Help button in the dialog 
box.

3. Click OK.

Figure 27 Insert Jump Menu dialog box
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How to create links
After you’ve set up a Dreamweaver site to store your website documents and have created HTML pages, you’ll want 
to create different types of links. Understanding the file path between the document you’re linking from and the 
document or asset you’re linking to is essential to creating links.

Each web page has a unique address, called a Uniform Resource Locator (URL). However, when you create a local 
link (a link from one document to another on the same site), you generally don’t specify the entire URL of the 
document you’re linking to; instead, you specify a relative path from the current document or from the site’s root 
folder. 

There are three types of link paths:

• Absolute paths provide the complete URL of the linked document, including the protocol to use (usually 
http:// for web pages). An example is, http://www.oceanviewhighschool.net/index.html. For an image asset, 
the complete URL is something like http://www.oceanviewhighschool.net/images/image1.jpg. You must use 
an absolute path to link to a document or asset in a different site.

• Document-relative paths are usually best for local links (within a website). They’re particularly useful when 
the current document and the linked document or asset are in the same folder and are likely to remain 
together. You can also use a document-relative path to link to a document or asset in another folder by 
specifying the path through the folder hierarchy from the current document to the linked document. For 
example, suppose you have a site with the structure shown in Figure 1:

Figure 1 Example site folder structure

◦ To link from contents.html to hours.html (both in the same folder), use the relative path hours.html.

◦ To link from contents.html to tips.html (in the resources subfolder), use the relative path resources/
tips.html. At each slash (/), you move down one level in the folder hierarchy.

◦ To link from contents.html to index.html (in the parent folder, one level above contents.html), use the 
relative path ../index.html. Two dots moves you up two levels in the folder hierarchy (to the root folder) 
and /index.html moves you back down one level (to the index page).

◦ To link from contents.html to catalog.html (in a different subfolder of the parent folder), use the relative 
path ../products/catalog.html. Here, .. moves you up to the root folder, and /products moves you down to 
the products subfolder, and /catalog.html moves you to the catalog page. When you move files as a 
group—for example, when you move an entire folder, so that all the files inside that folder retain the 
same relative paths to each other—you don’t need to update document-relative links between those 
files. However, when you move an individual file that contains document-relative links, or an individual 
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file targeted by a document-relative link, you do need to update those links. (If you move or rename 
files using the Files panel, Dreamweaver updates all relevant links automatically.)

• Site root–relative paths describe the path from the site’s root folder to a document. You may want to use 
these paths if you are working on a large website that uses several servers, or one server that hosts several 
sites. However, if you are not familiar with this type of path, you should stick to document-relative paths.

Using Dreamweaver, you can easily select the type of document path to create for your links.

Four different types of links are discussed in this guide:

• An internal link goes to another page within in your site using a document-relative path.

• An external link goes to another site external to your own using an absolute path.

• A named anchor link goes to a specific position on a page within your site using a combination document-
relative path and anchor link.

• An e-mail link opens a blank e-mail message window in a user’s default e-mail client, with the recipient’s 
address filled in. 

Creating an internal link 

You can use the Properties panel and the Point-To-File icon to create links from an image, an object, or text to 
another document or file (Figure 2). Dreamweaver creates the links to other pages in your site using document-
relative paths.

Figure 2 Properties panel

To create a link to another document in your site:

1. Start Dreamweaver.

2. Open an existing file, or create a new, blank page and 
save the file.

Note: Always save a new file before creating a 
document-relative path; a document-relative path is not 
valid without a definite starting point. If you create a 
document-relative path before saving the file, 
Dreamweaver temporarily uses an absolute path 
beginning with file:// until the file is saved; when you 
save the file, Dreamweaver converts the file:// path to a 
relative path.

Point-To-File iconLink text box Browse For File button Target menu
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3. Select text or an image in the Document window’s 
Design view.

4. Open the Properties panel (Window > Properties) and do 
one of the following:

• Drag the Point-To-File icon (target icon) to a 
document in the Files panel (Figure 2).

• Click the Browse For File button to browse to and 
select a file.

• Type the path and filename of the document in the 
Link text box.

Creating an external link

To link to a document outside your site, enter an absolute path, including the protocol (such as http://). You can enter 
these by hand or copy them from a browser address bar and paste them into the Link text box in the Properties panel. 

To add  a link to a page on another site:

1. Select an image or text you want to format as a link.

2. In the Link text box in the Properties panel, type or paste 
the address (URL) of the site to which you want to link.

Note: If you’re linking to a page outside of your site, it is 
a best practice to set the Target menu to 
target="_blank"  (Figure 3). This causes the link to 
open in a new browser window, so that the page doesn’t 
appear to be part of your site.

Figure 3 Properties panel, Target menu

Creating a link to a named anchor

To link to a particular section of a document, first create a named anchor at that location, and then link to the named 
anchor. Named anchors are frequently placed at the beginning of each topic and at the top of a document, so users can 
readily go to these locations. 

To create and link to a named anchor:

1. Position the insertion point at the location on the page 
where you want to define an anchor.

2. Select Insert > Named Anchor. 

The Named Anchor dialog box opens (Figure 4).

3. Enter a short anchor name without any spaces.

4. Click OK.

5. Select an image or text to link to the named anchor.

Figure 4 Named Anchor dialog box
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6. In the Link text box in the Properties panel, type # and 
then type or paste the anchor name. 

In the example code (Figure 5), an anchor named Top is 
placed at the top of the document, and a link to the anchor 
added at the bottom of the page.

Note: Anchor names are case-sensitive.

You can also use any ID attribute as a destination anchor 
so that links can be made to divisions, paragraphs, and 
most other elements.

Figure 5 Named Anchor dialog box

Creating a link to an e-mail address

When a user clicks an e-mail link, a new blank message window opens, using the mail program associated with the 
user’s browser. In the e-mail message window, the To box is automatically updated with the address specified in the 
e-mail link.

To create a link to an e-mail address:

1. In the Document window’s Design view, position the 
insertion point where you want the e-mail link to appear, 
or select the text or image you want to appear as the e-
mail link. 

2. Do one of the following to insert the link:

• Select Insert > Email Link.

• In the Common category of the Insert bar, click the 
Email Link button.

The Email Link dialog box opens (Figure 6).

3. In the Text box, enter text for the link.

If you selected text to format as the link, that text appears 
in the Text box.

4. In the Email text box, type the e-mail address.

5. Click OK to close the Email Link dialog box.

Figure 6 Email Link dialog box
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How to create lists
You can create numbered (ordered) lists, bulleted (unordered) lists, and definition lists from existing text or from new 
text as you type in the Document window. Definition lists do not use leading characters such as bullet points or 
numbers and are often used in glossaries or descriptions. Lists can also be nested. Nested lists are lists that contain 
other lists. For example, you might want an ordered or bulleted list nested within another numbered or unordered list.

Creating lists

In Adobe Dreamweaver, you can easily create lists to organize information. You can use the Properties panel to set 
list style (Figure 1). To set the appearance of an entire list or for an individual list item, use the List Properties panel. 
You can set number style, reset numbering, or set bullet style options for individual list items or for the entire list.

Figure 1 Properties panel

To create a new list:

1. Open a document in Dreamweaver.

2. Place the insertion point where you want to add a list, 
then do one of the following:

• In the HTML Properties panel, click either the 
Unordered  List button or the Ordered List button 
(Figure 1).

• Select Format > List and select the type of list 
desired—Unordered (bulleted) List, Ordered 
(numbered) List, or Definition List (Figure 2).

The leading character for the specified list item 
appears in the Document window.

3. In turn, type the text for a list item, and then press Enter 
(Windows) or Return (Mac OS) to create another list 
item.

4. To complete the list, press Enter twice (Windows) or 
press Return twice (Mac OS).

Figure 2 Format menu

To create a list using existing text:

1. Select a series of paragraphs to make into a list.

Unordered List

Ordered List Outdent

Indent
© 2012 Adobe Systems Incorporated How to create lists 1

This document requires Adobe Dreamweaver CS6. Technical instructions may differ depending on your version.



Guide Adobe Dreamweaver

2

Each paragraph will become an item in the new list.

2. In the HTML Properties panel, click the Unordered or 
Ordered List button, or select Format > List and select the 
type of list desired—Unordered List, Ordered List, or 
Definition List.

The list is created (Figure 3).

Figure 3 Create an ordered list

To create a nested list:

1. Select the list items you want to nest.

2. In the HTML Properties panel, click the Indent button, or 
select Format > Indent.

Dreamweaver indents the text and creates a separate list 
with the original list’s HTML attributes (Figure 4).

3. Apply a new list type or style to the indented text by 
following the same procedure used above.

Figure 4 Create a nested list 

To set list properties for an entire list:

1. In the Document window, create at least one list item. 
The new style will automatically apply to additional 
items you add to the list.

2. With the insertion point in the text of the list item, select 
Format > List > Properties to open the List Properties 
dialog box (Figure 5).

3. Set the options you want to define the list:

List Type specifies list properties while List Item 
specifies an individual item in a list. Use the pop-up 
menu to select a Bulleted List, Numbered List, or 
Definition List. Depending on the List Type you select, 
different options appear in the dialog box.

Style determines the style of numbers or bullets used for a 
numbered or bulleted list. All items in the list will have 
this style unless you specify a new style for items within 
the list.

Start Count sets the value for the first item in a numbered 
list.

4. Click OK to set the choices.

Figure 5 List Properties dialog box
How to create lists © 2012 Adobe Systems Incorporated

This document requires Adobe Dreamweaver CS6. Technical instructions may differ depending on your version.



Adobe Certified Associate 
Dreamweaver CC—Study Guide Sample Questions 

RESPONSE EXAMPLES 
 
1. When discussing the design plans for an e-commerce site with a retailer moving online, which 
goal would address the target audience? 
 

A. Increase brand/name recognition 
B. Focus on a specific market for online sales 
C. Include tracking so traffic can be analyzed 
D. Receive online feedback from customers 

 
Correct Answer: B 
 
2. Which three items might appear on the project plan when discussing an upcoming website with 
a design team? (Choose three.) 
 

A. Due dates 
B. Planning and Analysis 
C. Payment details 
D. Development timeline 

 
Correct Answer: A, B, and D 
 
3. Based on best practices, which three site elements should remain consistent throughout when 
designing a website? (Choose three.) 
 

A. Page layout 
B. Font formatting 
C. Navigation buttons 
D. Image placement 
E. Image file formats 

 
Correct Answer: A, B, and C 
 
4.  Which element or idea would NOT be used to improve website usability? 
 

A. Site maps 
B. Use of tables for complex data 
C. Consistent navigation 
D. Avoid using images 

 
Correct Answer: D 



  
5.  Which three elements are new to HTML5? (Choose three.) 
 

A. Figure 
B. Video 
C. Audio 
D. Body 

 
Correct Answer: A, B, and C 
 
6.  Which option is a capability of Dreamweaver for editing or altering an image? 
 

A. Cropping an image 
B. Scaling an image 
C. Changing the brightness of an image 
D. Changing the contrast of an image 

 
Correct Answer: B 
 
7.  Which HTML element assists in increasing your site’s popularity by helping search engines to 
index the site properly? 
 

A. <index> tags 
B. <meta> tags 
C. <head> tags 
D. <body> tags 

 
Correct Answer: B 
 
8.  Which file management technique allows a user to notify other group members that they are 
working on a specific file, and it should not be altered by them? 
 

A. Using the Check In feature 
B. Using the Check Out feature 
C. Using the Put feature 
D. Using the Get feature 

 
Correct Answer: B 
 
9.  Which Dreamweaver Site setup options allows the user to exclude all files that end with the 
extension .fla from all site operations? 
 

A. Contribute 
B. Cloaking 
C. jQuery 
D. Site Root 

 
Correct Answer: B 
 



10.  Which option is NOT a benefit of using HTML5 to include video in a web page? 
 

A. Use on iOS devices that do not support Flash 
B. No browser plug-ins required 
C. Supports video in native formats 
D. It works on all versions of all browsers 

 
Correct Answer: D 

SIMULATION EXAMPLES 

1. Close the CSS Transitions panel, and then save the workspace as a new Workspace Layout 
named Custom. 

Method of Completion: 

1. Right click on the panel text “CSS Transitions” OR Click on the down arrow on the right side of 
the panel “CSS Transitions” 

2. Click Close or Close Tab Group 
3. In the top menu, click “Window”  
4. Click Workspace Layout 
5. Click New Workspace 
6. Enter “Custom” in the text box 

OR 
1. Right click on the panel text “CSS Transitions” 
2. Click Close or Close Tab Group 
3. Click on the view menu at the top right of the screen 
4. Click New Workspace 
5. Enter “Custom” in the text box 

 
 
2.  Create a new HTML page, and save it to the documents folder as index.html. (Note: Accept all 
other default settings.)  
 

 
 



Method of Completion: 

1. In the Welcome screen, click “HTML” 
2. Click File at the top of the screen 
3. Click Save or Save As 
4. Confirm that the file is being saved in the documents folder 
5. In the name entry field, type “index” 
6. Click OK 

OR 
1. In the Welcome screen, click “HTML” 
2. Click “Ctrl + S” 
3. Confirm that the file is being saved in the documents folder 
4. In the name entry field, type “index” 
5. Click OK 

OR 
1. In the Welcome screen, click “More” 
2. Click HTML 
3. Click <none> 
4. Click OK 
5. Click File at the top of the screen 
6. Click Save or Save As 
7. Confirm that the file is being saved in the documents folder 
8. In the name entry field, type “index” 
9. Click OK 

 
 
3. Import the text from rhinoceros.docx into the current html file. 
 
Method of Completion: 

1. Click File 
2. Click Import 
3. Click Word Documents 
4. Click the file “rhinoceros” 
5. Click Open 

 
 
4.  Add an email link to the line of text at the bottom that begins with Click here to send. Use the 
link jimdean@certiport.com. 
 
Method of Completion: 

1. Highlight the text “Click here to send a email to ask a question or make a request.” 
2. In the properties panel, make sure “HTML” is selected on the left. 
3. Click in the text box next to Link and type mailto:jimdean@certiport.com 

OR 
1. Click on the code or the split view on the top left of the screen 
2. Put “<a href="mailto:jimdean@certiport.com">” directly before the text “Click here to send a 

email to ask a question or make a request” 



3. Put </a> directly after that same text 
OR 

1. Highlight the text “Click here to send a email to ask a question or make a request.” 
2. Click Insert from the menu above and Click Hyperlink OR Go to the Insert Panel under 

“Common” and click “Hyperlink” 
3. Type in “mailto:jimdean@certiport.com” in the text box next to Link 
4. Click OK 

 
 
5. Using Split view, enter into Live view, and then turn on Inspect mode. 
 
Method of Completion: 

1. At the top left of the screen, click View > Code and Design 
2. Next to split, click “Live” 
3. Lastly, next to Live Code, click “Inspect” 

OR 
1. Click View in the menu above 
2. Click Split View 
3. Click View again in the menu above 
4. Click Live View 
5. Click View one more time 
6. Click Inspect 

 
 
6.  In a table, merge the two cells that contain paragraph text. 
 

 
 
Method of Completion: 

1. Click in one of the cells with paragraph text 
2. Hold down shift while clicking in the other cell with paragraph text (you might need to click 

twice) 
3. Right click somewhere in the selection 
4. Click Table 
5. Click “Merge Cells” 

OR 
1. Click in one of the cells with paragraph text 
2. Hold down shift while clicking in the other cell with paragraph text (You might need to click 

twice) 
3. In the menu above, click “Modify” 



4. Click Table 
5. Click “Merge Cells” 

 
 
7.  Add a Password form element directly below the text Enter User Name. Set the placeholder to 
the form entry box as Enter Password, the Max Length of the form validation to 8, and make it 
required. 
 

 
 
Method of Completion: 

1. Click within the form section of the current web page, below the text “Enter User Name” 
2. In the Insert panel, click the dropdown to menu and click “Form” 
3. Click Password within the Form section 
4. Click on the text box next to the word “Password” 
5. In the properties panel below, click in the text box next to placeholder and type “Enter 

Password” 
6. Click in the text box next to “Max Length” and type “8” 
7. Check the box next to “Required” 

OR 
1. Click within the form section of the current web page, below the text “Enter User Name” 
2. Click “Insert” from the menu above” 
3. Click “Form”   
4. Click “Password” 
5. Click on the text box next to the word “Password” 
6. In the properties panel below, click in the text box next to placeholder and type “Enter 

Password” 
7. Click in the text box next to “Max Length” and type “8” 
8. Check the box next to “Required” 

 
 
8.  Using Design view and Live view, change the position of the div tag with the ID of Title to 
relative. 
 



 
 
Method of Completion: 

1. In the CSS Designer panel, click “animals.css” 
2. In the selectors section of the CSS Designer panel, Click “#Title” 
3. Under the Properties section of the CSS Designer panel, click the box next to “Show Set” 
4. Next to “Position” Change the selection to “Relative” 

OR 
1. At the top of the screen, click “animals.css” 
2. In the CSS file, change the value next to “position:” to “relative” 

 
 
9.  Change the paragraph text in the div tag with the ID of Snakes to the following specifications: 
 

• Font-family: Gotham, Helvetica Neue, Helvetica, Arial, sans-serif 
• Font-size: 12 px 
• Color: #03C 

 

 
 
Method of Completion: 

1. Click in the paragraph about the Snakes 
2. In the breadcrumbs below, click <p> to select the paragraph. Alternitavely, the user could just 

highlight the whole paragraph starting with the text “Snakes are…” 
3. In the properties panel below, Click “CSS” on the left 
4. In the properties panel below, change the font to “Gotham, Helvetica Neue, Helvetica, Arial, 

sans-serif” 
5. Next to Font, change the font size to 12 



6. Lastly in the same area, click on the text box next to the color picker and type “#03C 
OR 

1. Click in the paragraph about the Snakes 
2. In the breadcrumbs below, click <p> to select the paragraph. Alternitavely, the user could just 

highlight the whole paragraph starting with the text “Snakes are…” 
3. Use the CSS Designer panel to select the three criteria above 

 
 
10.  Create a new CSS style sheet named default.css, and do the following: 

• Save it in the Documents folder.  
• Attach it as an external style sheet to the HTML document.  
• Create a new rule in the style sheet that sets the background color of the web page to 

#FFFFCC. 
• Set the font-family to Lucida Grande, Lucida Sans Unicode, Lucida Sans, DejaVu Sans, 

Verdana, sans-serif.  
 
Method of Completion: 

1. With WebDesignContest.html open. From the menu select File > New > CSS. 
2. Right click on the untitled CSS file and click save or save as or from the menu select File > Save 

or from the menu select File > Save As 
3. Save the document as default.css and click save. 
4. Return to WebDesignContest.html tab and Select Format > CSS Styles > Attach Stylesheet. OR 

Click on the ‘plus’ sign under Sources in the CSS Designer panel and select Attach an existing 
CSS File 

5. Browse to the location of the default.css stylesheet just created. Click ok. 
6. Click on the ‘plus’ sign in the Selectors section of the CSS Designer panel 
7. Under Properties, click the Text icon and change the family to Lucida Grande, Lucida Sans 

Unicode, Lucida Sans, DejaVu Sans, Verdana, sans-serif. 
8. Under Properties, click the Background icon and change the background-color to #FFFFCC (or 

#FFC) 
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